This project is read-only.

No menu entries for WSCF

Sep 18, 2009 at 2:19 PM

I have installed WSCF Blue with Visual Studio 2008 SP1. The installation completed correctly, but when I right click on an XSD or WSDL file, I do not get any new menu items. I checked the 'help about' and WSCF blue is listed as an installed option. I tried creating a new project, both WCF Service Library and console application, but that did not help.

Any suggestions?



Sep 18, 2009 at 5:33 PM

Can you check whether is enabled via "Tools - Add-In Manager..." and then check that is enabled.


Sep 18, 2009 at 6:59 PM

Yes, that solved the problem! Sorry for such a basic mistake and thanks for the fast response.




Feb 11, 2010 at 2:20 PM
Edited Feb 19, 2010 at 4:25 AM

Sorry to pick up an old thread, but i think its useful to continue this discussion for the reference of others rather than start a new one.  I too am experiencing this issue - i have Visual Studio 2008 Professional SP1.  I can see that in Tools -> Add-in Manager WSCF 1.0.5 is installed and enabled.  I can see the "Web Services Contract First ..." menu item under the Tools menu.  However when i right-click an XSD file, the context menu does not appear.  I dont know how to generate the message types any other way.  Can you please give me some suggestions to try.

cheers, Lou (Procreate, while (true) Blog();)

Feb 15, 2010 at 12:53 PM

Hi Xcalibur,

I have some instructions on how to enable logging in Hopefully the log file will capture some useful information for us.

Create a file called Thinktecture.Tools.Web.Services.ContractFirst.dll.config in the installation folder. It should be in the same folder as the Thinktecture.Tools.Web.Services.ContractFirst.dll file.

Paste the XML below into the configuration file.

<?xml version="1.0" encoding="utf-8"?>
    <add key="trace" value="true" />

Run and right-click on the XSD files. The log file will be created in the installation folder and will be called WSCF.log. You can post any exceptions you find in the log file here, or organise to email me the log file by contacting me through my profile page here on CodePlex.



Feb 16, 2010 at 8:35 AM
Edited Feb 19, 2010 at 4:25 AM

Thanks for the info Alex.

First of all for future reference, when i followed your instructions it caused the addin to throw an exception and VS to prompt me to disable it.  I worked out this is a permissions problem due to the security model in Windows 7 - after creating WSCF.log in the directory and giving all users full access to it, VS was able to start fine.

Below is the important parts of the generated log file with surrounding entries for context:

1-01-2008 16:09
A new instance of WSCF Connect class is created.

1-01-2008 16:09
Entering OnConnection method.

1-01-2008 16:09
Creating commands.

1-01-2008 16:09
Command bar is added to the Tools menu.

1-01-2008 16:09
System.NullReferenceException: Object reference not set to an instance of an object.
   at Microsoft.PowerCommands.Commands.ShowAllFilesCommand.CanExecute(OleMenuCommand command)
   at Microsoft.PowerCommands.Commands.DynamicCommand.OnBeforeQueryStatus(Object sender, EventArgs e)
   at Microsoft.VisualStudio.Shell.OleMenuCommand.get_OleStatus()
   at Microsoft.VisualStudio.Shell.OleMenuCommandService.Microsoft.VisualStudio.OLE.Interop.IOleCommandTarget.QueryStatus(Guid& guidGroup, UInt32 nCmdId, OLECMD[] oleCmd, IntPtr oleText)
   at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.OLE.Interop.IOleCommandTarget.QueryStatus(Guid& guidGroup, UInt32 nCmdId, OLECMD[] oleCmd, IntPtr oleText)
   at Microsoft.VisualStudio.CommandBars._CommandBars.get_Item(Object Index)
   at Thinktecture.Tools.Web.Services.ContractFirst.Connect.OnConnection(Object application, ext_ConnectMode connectMode, Object addInInst, Array& custom)

1-01-2008 16:09
Value does not fall within the expected range.

1-01-2008 16:09
Value does not fall within the expected range.

1-01-2008 16:09
Value does not fall within the expected range.

1-01-2008 16:09
Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))

1-01-2008 16:09
Value does not fall within the expected range.

1-01-2008 16:09
Paste Schema code menu item is added

1-01-2008 16:09
Leaving OnConnection method.

Based on my above experience i would guess some permission-related issue.  If you can tell me how to debug the addin, im happy to step through the code if it will help.

cheers, Lou (Procreate, while (true) Blog();)

Feb 18, 2010 at 12:52 PM

Hi Lou,

It looks like you have the PowerCommands for Visual Studio 2008 installed. Can you please try uninstalling that add-in and let me know if the problem still occurs?



Feb 19, 2010 at 4:24 AM

It probably will, i have read this elsewhere with different addins - will try later and let you know.  Is there any way to get the two addins to co-exist?

cheers, Lou (Procreate, while (true) Blog();)

Feb 21, 2010 at 12:00 PM

I'm not sure Lou. I installed the 1.1 version of PowerCommands and managed to reproduce the problem, but only once. It was the first time I used after installing PowerCommands that the problem occurred. Unfortunately, I could not reproduce the problem again after that.

Mar 2, 2010 at 2:22 PM


  It may or may not be relevant.  But I experienced the same problem on the first launch of VS2008 after installing WSCF.Blue but on subsequent launches it was fine.  I have a couple of other addins enabled (ANTS memory and performance profilers, and DevExpress Tools).

Maybe this info will help with a diagnosis.  If I can give any more info let me know


Mar 7, 2010 at 1:28 PM

Thanks for the information Joe. I am sure it more than a coincidence that you have experienced what seems to be the same problem. Unfortunately it will be a pain to debug given the steps required to reproduce the problem. I will take a look at this again the next time I am doing some installer work and have to install and uninstall anyway.