This project is read-only.

ReplyAction="*"

Jul 16, 2009 at 1:41 PM

When the interface class is created, the Action attribute is being set, but the ReplyActioin is being set to *.  This is causing issues with connecting/using the service.  If I add a correct value to the ReplyAction I have success.  I am wondering if I am missing something in my schema or wsdl that is causing the ReplyAction="*"?

 

thanks

 

Jul 24, 2009 at 11:46 AM

Hi,

I have noticed this with some other WSDLs and using svcutil as well, so i think its something in the core of ServiceContractGenerator  (which is used in both WSCF and Svcutil) .

We have added a feature that allows the replyAction to be constructed and are currently doing a round of testing and will make a patch available as soon as possible.

- Benjy

Jul 24, 2009 at 11:46 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Jul 25, 2009 at 9:46 AM

Hi dgulley,

A fix for this has been checked in as part of change set 35411. We should have a binary patch available soon but you can compile from the change set below if you are really keen.

http://wscfblue.codeplex.com/SourceControl/changeset/view/35411

There is a new option called "Format SOAP Action" on the Code Generation dialog. It will ensure the SOAP actions (Action and ReplyAction) applied to each operation contract follow the standard WCF format: <namespace>/<service>/<operation>[Response]

e.g. [System.ServiceModel.OperationContractAttribute(Action="http://www.thinktecture.com/RestaurantService/getRestaurants", ReplyAction="http://www.thinktecture.com/RestaurantService/getRestaurantsResponse")]

Thank you for reporting the issue.

Cheers,

Alex.

Jul 27, 2009 at 1:28 PM
Thanks! I will give a try when I have a chance.


From: [email removed]
To: [email removed]
Date: Sat, 25 Jul 2009 01:46:10 -0700
Subject: Re: ReplyAction="*" [WSCFblue:62620]

From: alexmeyergleaves
Hi dgulley,
A fix for this has been checked in as part of change set 35411. We should have a binary patch available soon but you can compile from the change set below if you are really keen.
http://wscfblue.codeplex.com/SourceControl/changeset/view/35411
There is a new option called "Format SOAP Action" on the Code Generation dialog. It will ensure the SOAP actions (Action and ReplyAction) applied to each operation contract follow the standard WCF format: <namespace>/<service>/<operation>[Response]

e.g. [System.ServiceModel.OperationContractAttribute(Action="http://www.thinktecture.com/RestaurantService/getRestaurants", ReplyAction="http://www.thinktecture.com/RestaurantService/getRestaurantsResponse")]
Thank you for reporting the issue.
Cheers,
Alex.
Jul 27, 2009 at 5:49 PM
doesn't seem to work for a client side proxy, index out of range.

works with service side stub


From: [email removed]
To: [email removed]
Date: Sat, 25 Jul 2009 01:46:10 -0700
Subject: Re: ReplyAction="*" [WSCFblue:62620]

From: alexmeyergleaves
Hi dgulley,
A fix for this has been checked in as part of change set 35411. We should have a binary patch available soon but you can compile from the change set below if you are really keen.
http://wscfblue.codeplex.com/SourceControl/changeset/view/35411
There is a new option called "Format SOAP Action" on the Code Generation dialog. It will ensure the SOAP actions (Action and ReplyAction) applied to each operation contract follow the standard WCF format: <namespace>/<service>/<operation>[Response]

e.g. [System.ServiceModel.OperationContractAttribute(Action="http://www.thinktecture.com/RestaurantService/getRestaurants", ReplyAction="http://www.thinktecture.com/RestaurantService/getRestaurantsResponse")]
Thank you for reporting the issue.
Cheers,
Alex.
Jul 28, 2009 at 1:02 PM

Hi dgulley,

Sorry, I completely missed that. I have checked in another fix that ensures the option works for both client and service code generation. You can grab the source from the change set below:

http://wscfblue.codeplex.com/SourceControl/changeset/view/36209

The name of the interface implemented by the service contract is now always used in the formatted SOAP action instead of the service contract class name.

e.g. Action="http://www.thinktecture.com/IRestaurantService/getRestaurants" instead of Action="http://www.thinktecture.com/RestaurantService/getRestaurants"

This change was required to make sure the option works for both client and service code generation, but actually follows the normal WCF behaviour for Action and ReplyAction more closely:

The default action value is a combination of the contract namespace (the default value is "http://tempuri.org/"), the contract name (interface name or the class name, if no explicit service interface is used), the operation name, and an additional string ("Response") if the message is a correlated response.

Thanks for testing this and getting back to me.

Cheers,

Alex.

Jul 29, 2009 at 2:30 PM
works great thanks man!


From: [email removed]
To: [email removed]
Date: Tue, 28 Jul 2009 05:02:40 -0700
Subject: Re: ReplyAction="*" [WSCFblue:62620]

From: alexmeyergleaves
Hi dgulley,
Sorry, I completely missed that. I have checked in another fix that ensures the option works for both client and service code generation. You can grab the source from the change set below:
http://wscfblue.codeplex.com/SourceControl/changeset/view/36209
The name of the interface implemented by the service contract is now always used in the formatted SOAP action instead of the service contract class name.

e.g. Action="http://www.thinktecture.com/IRestaurantService/getRestaurants" instead of Action="http://www.thinktecture.com/RestaurantService/getRestaurants"
This change was required to make sure the option works for both client and service code generation, but actually follows the normal WCF behaviour for Action and ReplyAction more closely:

The default action value is a combination of the contract namespace (the default value is "http://tempuri.org/"), the contract name (interface name or the class name, if no explicit service interface is used), the operation name, and an additional string ("Response") if the message is a correlated response.

Thanks for testing this and getting back to me.
Cheers,
Alex.