This project is read-only.

DTD is prohibited in this XML document

May 31, 2011 at 9:46 PM

Hello.

I recently downloaded this tool and ran its sample (Restaurant). Everything went thru perfectly fine.

Then i wanted to create this webservice using this company's .XSD. When i try to create the Web Service Code (after succesfully creating the WSDL), i get this error.

- The WSDL document contains links that could not be resolved.
- DTD is prohibited in this XML document.

the only difference between your sample project and my webservice is that i am afraid this company's .xsd are using some .dtd behind scenes (i can see them in the solution folder)

is there a fix to this? workaround? solution? anything?

thanks

 

Jun 6, 2011 at 4:07 PM

Hello? Can at least get a "Not a clue" response from the creators of this tool? :)

Jun 6, 2011 at 4:16 PM

If you attempt to generate a proxy for the WSDL using svcutil.exe do you receive the same error? WSCF.blue uses many of the same .NET Framework classes as svcutil.exe under the hood so often the same restrictions apply.

Jun 7, 2011 at 3:28 PM

Hello Alex

I was able to use the wsdl from command prompt. It worked fine but of course, i don't know if that would be the same result as using WSFC.blue generator.

WSCF uses wsdl or svcutil?

Jun 8, 2011 at 3:21 PM

It does not use either directly, but does use some of the same framework classes that svcutil.exe does. If you are not concerned about posting your WSDL can you raise a bug in the Issue Tracker and attach the problem WSDL (and associated files)?

Jun 8, 2011 at 4:47 PM

Not a problem at all. I am using an open standard (ACORD) for Insurance Companies. I am gonna attach the WSDL generated by WSCF.blue and the .xsd, .dtd provided to me by this company.

Jun 8, 2011 at 4:53 PM

DONE. Added to the Issue Tracker