Not Registered in the extension collection 'behaviorExtension' Error.

Sep 14, 2009 at 10:57 PM

When creating the web service code from the WSDL and selecting the Enable WSDL Endpoint I get the error below.  Please advise.

system.configuration.configurationerrorsexception: the extension of type 'thinktecture.servicemodel.extensions.metadata.staticmetadatabehaviorelement, thinktecture.serviemodel.extension.metadata, version=1.0.2.0, ............................. is not registered in the extension collection 'behaviorExtensions' 

 

 

 

Sep 16, 2009 at 11:45 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Sep 16, 2009 at 11:51 AM

Hi Michael,

I have checked in a fix for this. The issue was in the ConfigurationDecorator class where we were adding the metadata assembly and the version wasnt correct (it should be 1.0.3.0 to correspond with the release)

I need to discuss with the team whether we want to update the MSI.

Are you working with the source or the MSI ?

Thanks

Benjy

Sep 16, 2009 at 5:47 PM

Hi Benjy,

I'm working through the MSI.

Thanks,

Sep 17, 2009 at 3:00 PM

Hi Benjy,

I may have mistyped above, because the version is 1.0.3.0

Sep 18, 2009 at 11:50 AM

Hi,

Thats alright. The problem is that the assembly is at 1.0.3.0, but the code which sets up the fully qualified name uses a string with the original version 1.0.0.0 and hence the loading failure.  For the long term we will probably have to setup the string which contains the fully qualified name a bit more dynamically.

Apparently this happens to other folk using custom behaviors as well. The issue is documented in the Connect post here : https://connect.microsoft.com/wcf/feedback/ViewFeedback.aspx?FeedbackID=216431 

We'll update the MSI by this weekend.

Thanks

Benjy

Sep 22, 2009 at 9:28 AM

Hi  Michael,

The new MSI (1.0.4) is now ready and has replaced the old MSI as it is still Beta-2. Please try this out and let us know if the problem is solved.

Thanks

benjy

 

Sep 22, 2009 at 2:55 PM

Thank you.  I did get a new msi from Alex and all worked ok. 

Michael G.

From: santoshbenjamin [mailto:notifications@codeplex.com]
Sent: Tuesday, September 22, 2009 3:29 AM
To: Garcia, Michael
Subject: Re: Not Registered in the extension collection 'behaviorExtension' Error. [WSCFblue:68912]

From: santoshbenjamin

Hi Michael,

The new MSI (1.0.4) is now ready and has replaced the old MSI as it is still Beta-2. Please try this out and let us know if the problem is solved.

Thanks

benjy

Read the full discussion online.

To add a post to this discussion, reply to this email (WSCFblue@discussions.codeplex.com)

To start a new discussion for this project, email WSCFblue@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

****************************************************************************************** 
This message may contain confidential or proprietary information intended only for the use of the 
addressee(s) named above or may contain information that is legally privileged. If you are 
not the intended addressee, or the person responsible for delivering it to the intended addressee, 
you are hereby notified that reading, disseminating, distributing or copying this message is strictly 
prohibited. If you have received this message by mistake, please immediately notify us by  
replying to the message and delete the original message and any copies immediately thereafter. 

Thank you. 
****************************************************************************************** 
FACLD