Visual Studio 2013 support

May 8, 2014 at 10:19 AM
Has anyone been able to get the addin to work in VS 2013?

I've followed the recommendations on this post https://wscfblue.codeplex.com/discussions/399067

but unfortunately I had no luck on getting it to work in VS 2013.
May 15, 2014 at 7:48 AM
Edited May 15, 2014 at 7:49 AM
The post below provided by corneliu_dinca for Visual Studio 2012 worked also for Visual Studio 2013
just changed visual studio 2012 references to visual studio 13 and it worked

1) Go to "C:\Program Files (x86)\thinktecture\WSCF.blue"

2) Copy "WSCF.blue.VS2010.addin" and rename the copy to "WSCF.blue.VS2013.addin"

3) Open "WSCF.blue.VS2013.addin" with a text editor (eg Notepad++)

4) Change the host application's version number from 10.0 to 12.0 as follows:
  <HostApplication>
     <Name>Microsoft Visual Studio</Name>
     <Version>12.0</Version>
   </HostApplication>
5) If the path "C:\Program Files (x86)\thinktecture\WSCF.blue\" is not added in Visual Studio 2013 addin file-paths list, go in Visual Studio 2013's menu: Tools->Options->Environment->Add-in Security and then add the path

6) Restart the Visual Studio 2013 IDE
May 15, 2014 at 10:14 AM
WissamT wrote:
The post below provided by corneliu_dinca for Visual Studio 2012 worked also for Visual Studio 2013
just changed visual studio 2012 references to visual studio 13 and it worked

1) Go to "C:\Program Files (x86)\thinktecture\WSCF.blue"

2) Copy "WSCF.blue.VS2010.addin" and rename the copy to "WSCF.blue.VS2013.addin"

3) Open "WSCF.blue.VS2013.addin" with a text editor (eg Notepad++)

4) Change the host application's version number from 10.0 to 12.0 as follows:
  <HostApplication>
     <Name>Microsoft Visual Studio</Name>
     <Version>12.0</Version>
   </HostApplication>
5) If the path "C:\Program Files (x86)\thinktecture\WSCF.blue\" is not added in Visual Studio 2013 addin file-paths list, go in Visual Studio 2013's menu: Tools->Options->Environment->Add-in Security and then add the path

6) Restart the Visual Studio 2013 IDE
I tried it again using just plain old notepad and found out that I had to run it as Administrator to get past the Access Denied error when saving the file. I wasn't getting any error from Notepad++ and I thought it was saving the file correctly.

All is good again. Thanks.
Marked as answer by injunjoe76 on 5/15/2014 at 3:57 PM